Troubleshooting 2017-05-10T11:51:22+00:00


Note: Please test/troubleshoot all client issues before forwarding to us. Check the Community Forums and you can submit a case via the by clicking the create case button in lower left hand of the page.

Please make sure when e-mailing us about an issue that you include as much of the following as possible when reporting an issue:

  • Client’s domain name/AID, the issue you are experiencing
  • The behavior you are expecting
  • Any links to pages currently experiencing the issue
  • Screenshots of the issue
  • Steps to recreate
  • Any examples that will help us understand the issue fully

The following is a 12 point list for troubleshooting common IDX Broker issues. Not all possible issues can be covered here, but this list covers common issues reported and asked about.

Clients Listings Are Not Displaying

  • Make sure the agent ID’s are set:
  • Make sure the listing is specified to display via IDX in the MLS
  • Make sure the agent doesn’t have their name listed twice in the agent ID’s section. If they do try the other agent ID
  • Note: If you have it set as an office ID and there are more agents in your office than what the account level allows, the system will pick which agents’ listings it shows
  • Check when the listing was added to the MLS and when we last downloaded MLS data:

Listings Not Displaying On Site

  • Make sure that the listing is specified in the MLS to display via IDX
  • Check when the listing was added to the MLS and when we last downloaded MLS data:
  • Make sure that the listing is in the MLS that the client has enabled on their site

Images Not Displaying For Listing

  • Make sure the client did not add images via the IDX Dashboard. If client added images, then MLS provided images won’t overwrite.
  • In the account go to Listings > Active > Click on camera icon under tools column. In the top right corner try to revert to MLS data to see if the new images come in if the link is available.
  • Make sure that the MLS finished the update today if the client just added the images. You can check the last update time here:
  • Append ?nowrapper to the page to remove the wrapper make sure it’s an IDX Broker issue and not a wrapper issue. If there is already a ? in the url string use & nowrapper

City Not Showing In Clients City List

Agent is not showing on the assigned agent drop down:

Go into the IDX Dashboard and Edit the agent to look at his permissions:

(Make sure Display on Assigned Agent Menu is selected.)

Option value missing from advanced search fields:

  • We populate advanced search fields based on active listings in the MLS. If there is not an active listing in that field with that option value specified then the option value won’t show in the advanced field.
  • Double check that you are looking at the correct property type.

Wrapper not working:

Saved Links

When editing saved links please edit the link by hand. Try to remove any advanced field names or option values originally specified when the saved link was created.

Property Showing In Wrong Location On The Map

  • If this is your client’s listing then you can update the latitude and longitude via the IDX Dashboard:
  • If it is not your client’s listing, then you will need to send an e-mail to us at
  • It is not unusual for listings with the ambiguous address (such as Township being used as the city name) information to have incorrect coordinates or do no not have coordinates at all.

MLS settings and Changing labels not applied:

If you change a label using the MLS settings section and you don’t see it applied on the details page, then please double check that area by searching the field name and make sure you changed for each property type as you can’t only change once and have it applied to all.

Why Isn’t My Agent Showing On The Roster?

Sold Listings

Images Are Small On Results Pages And Widgets

Go to Preferenes –> Global Preferences –> Results –> Turn off thumbnails for results pages