[Support request] How can I do No Index No Follow on WP wrapper pages?2015-06-10T17:45:32+00:00

Build with IDX Broker Forums Enhancement Requests How can I do No Index No Follow on WP wrapper pages?

Tagged: ,

  • Author
    Posts
  • Allen White
    Participant
    Post count: 4

    Some of my clients’ WordPress wrapper pages are indexing on google and users are clicking them. How can I no-index these pages but still use it for IDX Broker Wrappers?

    0 ratings, 0 votes0 ratings, 0 votes (0 rating, 0 votes, rated)
    You need to be a registered member to rate this post.
    Loading...
  • imFORZAimFORZA
    Participant
    Post count: 68

    I have been wanting to write some permanent code for this to use for all of our clients, but here are some examples:

    Option 1) Update the robots.txt file for your site to block the url of your global wrapper url for all robots (EXCEPT the IDX Broker bot for your client).

    Option 2) Write a if statement, and set the wrapper page to noindex,nofollow for all visitors (EXCEPT the IDX Broker bot for your client). You could even write it to redirect everyone else so they can’t even see the wrapper page. Although I would make sure that you as a admin can still see it, for testing purposes.

    I can’t remember the name of the bot off the top of my head, but I’m sure one of the IDX Broker employees can mention it here.

    0 ratings, 0 votes0 ratings, 0 votes (0 rating, 0 votes, rated)
    You need to be a registered member to rate this post.
    Loading...
  • Antonio Ortega
    Keymaster
    Post count: 170

    The dynamic wrapper bot is explained here: http://support.idxbroker.com/customer/portal/articles/1919076-troubleshoot-dynamic-wrapper

    Another option would be to add No follow after this IDX robot tag Like so:

    <meta name='idx-robot'>
    <meta name='robots' content='noindex,nofollow'>

    After IDX runs the curl on the dynamic wrapper page, the system will strip out the line with and anything on the following line.

    This is how the WP plugin handles the no index tag.

    0 ratings, 0 votes0 ratings, 0 votes (0 rating, 0 votes, rated)
    You need to be a registered member to rate this post.
    Loading...

You must be logged in to reply to this topic.