[Support request] JetPack stats skewed from global wrapper page getting enormous amount of traffic2015-12-20T05:13:18+00:00

Build with IDX Broker Forums SEO JetPack stats skewed from global wrapper page getting enormous amount of traffic

Tagged: 

  • Author
    Posts
  • brightrealtorbrightrealtor
    Participant
    Post count: 2

    Would it be safe to disallow the wrapper page in robots.txt?

    Or alternative solution would be grate as client is asking questions about stats.

    Regards,
    BR

    2 ratings, 2 votes2 ratings, 2 votes (+2 rating, 2 votes, rated)
    You need to be a registered member to rate this post.
    Loading...
  • Antonio Ortega
    Keymaster
    Post count: 170

    robots.txt files cannot enforce crawler behavior to your site; instead, these instructions act as directives to the crawlers accessing your site. So disallowing the wrapper page to robots.txt should still allow the IDX Broker Dynamic Wrapper system the ability to cURL the page specified in the dashboard.

    As an alternative you could add the following meta tags in this exact order:

    <meta name='idx-robot'>
    <meta name='robots' content='noindex,nofollow'>

    to the wrapper page. This will be removed when IDX Broker wrapper system cURLs the page and not show on your wrapped IDX pages. The IDX Broker WordPress plugin uses these tags to keep a wrapper page from being indexed.

    2 ratings, 2 votes2 ratings, 2 votes (+2 rating, 2 votes, rated)
    You need to be a registered member to rate this post.
    Loading...
  • brightrealtorbrightrealtor
    Participant
    Post count: 2

    I apologies, I meant to say .htaccess

    2 ratings, 2 votes2 ratings, 2 votes (+2 rating, 2 votes, rated)
    You need to be a registered member to rate this post.
    Loading...
  • imFORZAimFORZA
    Participant
    Post count: 68

    Another option might be to disable Jetpack stats on the wrapper pages. This would add the extra benefit of not loading any js or css that may be used for jetpack stats. I did a quick google search and came up with some quick code:

    <?php
    add_action( 'template_redirect', 'idxbroker_disable_jetpack_stats' );
    function idxbroker_disable_jetpack_stats() {
      // Check that we are on a single IDX Wrapper
      if ( is_singular('idx-wrapper') ) {
        remove_action( 'wp_footer', 'stats_footer', 101 );
        remove_action( 'wp_head', 'stats_add_shutdown_action' );
      }
    }

    I saved it on github as well:
    https://gist.github.com/bhubbard/d075c601d05cafd69984

    I haven’t had the chance to test it yet, but if it works well, I suggest we have IDX Broker add this to the plugin. You will also need to make sure your site uses the wrappers in the latest version of the IDX Broker WordPress plugin.

    2 ratings, 2 votes2 ratings, 2 votes (+2 rating, 2 votes, rated)
    You need to be a registered member to rate this post.
    Loading...
  • Antonio Ortega
    Keymaster
    Post count: 170

    Disallowing via .htaccess is also ok as long as the IDX cURL can still reach the wrapper page. I would be sure I was not blocking all google crawling. If this is WordPress wrappers created via the WP plugin already have No Index applied to those specific pages as shown above.

    2 ratings, 2 votes2 ratings, 2 votes (+2 rating, 2 votes, rated)
    You need to be a registered member to rate this post.
    Loading...

You must be logged in to reply to this topic.